Selasa, 19 Mei 2009

Configuring OSPF

Topology Case






Router 0
Router>enable
Router#configure terminal
Router(config)#interface serial 0/0
Router(config-if)#ip address 172.16.1.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#clock rate 64000
Router(config-if)#exit
Router(config)#router ospf 100
Router(config-router)#network 172.16.1.0 0.0.0.255 area 0

Router 1

Router>enable
Router#configure terminal
Router(config)#interface serial 0/0
Router(config-if)#ip address 172.16.1.2 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#clock rate 64000
Router(config-if)#exit
Router(config)#interface serial 0/1
Router(config-if)#ip address 172.16.2.1 255.255.255.0
Router(config-if#no shutdown
Router(config-if)#exit
Router(config)#router ospf 300
Router(config-router)#network 172.16.1.0 0.0.0.255 area 0
Router(config-router)#network 172.16.2.0 0.0.0.255 area 0

Router 2
Router>enable
Router#configure terminal
Router(config)#interface serial 0/0
Router(config-if)#ip address 172.16.2.2 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#clock rate 64000
Router(config-if)#exit
Router(config)#router ospf 150
Router(config-router)#network 172.16.2.0 0.0.0.255 area 0



After Completing this Configuration You should verify our configuration and network connectivity by doing this step :

1.Go To Router 1
2.Type this command :
Ping Ip Address
3.Go To Router 2
4.Type this command
Show Running-Config ⇒ Displaying Router Configuration
Show ip protocols → Displaying Description about routing protocol that has been used
Show ip route ⇒ Displaying How Packet Data is routed & Transmitted between Node

Configuring IGRP

Topology Case






Router 0
Router>enable
Router#configure terminal
Router(config)#interface serial 0/0
Router(config-if)#ip address 172.16.1.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#clock rate 64000
Router(config-if)#exit
Router(config)#router igrp 10
Router(config-router)#network 172.16.1.0

Router 1

Router>enable
Router#configure terminal
Router(config)#interface serial 0/0
Router(config-if)#ip address 172.16.1.2 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#clock rate 64000
Router(config-if)#exit
Router(config)#interface serial 0/1
Router(config-if)#ip address 172.16.2.1 255.255.255.0
Router(config-if#no shutdown
Router(config-if)#exit
Router(config)#router igrp 10
Router(config-router)#network 172.16.1.0
Router(config-router)#network 172.16.2.0

Router 2
Router>enable
Router#configure terminal
Router(config)#interface serial 0/0
Router(config-if)#ip address 172.16.2.2 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#clock rate 64000
Router(config-if)#exit
Router(config)#router igrp 10
Router(config-router)#network 172.16.2.0

Minggu, 17 Mei 2009

How To Configure RIP Protocol

Topology Case




Router 0
Router>enable
Router#configure terminal
Router(config)#interface serial 0/0
Router(config-if)#ip address 172.16.1.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#clock rate 64000
Router(config-if)#exit
Router(config)#router rip
Router(config-router)#network 172.16.1.0

Router 1

Router>enable
Router#configure terminal
Router(config)#interface serial 0/0
Router(config-if)#ip address 172.16.1.2 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#clock rate 64000
Router(config-if)#exit
Router(config)#interface serial 0/1
Router(config-if)#ip address 172.16.2.1 255.255.255.0
Router(config-if#no shutdown
Router(config-if)#exit
Router(config)#router rip
Router(config-router)#network 172.16.1.0
Router(config-router)#network 172.16.2.0

Router 2
Router>enable
Router#configure terminal
Router(config)#interface serial 0/0
Router(config-if)#ip address 172.16.2.2 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#clock rate 64000
Router(config-if)#exit
Router(config)#router rip
Router(config-router)#network 172.16.2.0

After Completing this Configuration You should verify our configuration and network connectivity by doing this step :

1.Go To Router 1
2.Type this command :
Ping Ip Address
3.Go To Router 2
4.Type this command
Show Running-Config ⇒ Displaying Router Configuration
Show ip protocols → Displaying Description about routing protocol that has been used
Show ip route ⇒ Displaying How Packet Data is routed & Transmitted between Node

Rabu, 25 Februari 2009

Configuring WAN Links with EIGRP

EIGRP Support different WAN Links :
- Point to point links
- NBMA
o Multipoint Links
o Point to point links
EIGRP Uses up to 50 % of bandwith by default ;this bandwith utilization can be changed


Point to Point Links



Point to multipoint Links ( Hub & Spoke )





Bandwith utilization over point to point sub interfaces using Frame Relay :
Treats bandwith T1 as by default
Should Manually Configure bandwith as the CIR of the PVC

Bandwith utilization over multipoint frame relay,ATM and ISDN PRI
EIGRP used the physcal bandwith on the interface divided by the number of neighbors on that interface to calculate the bandwith attributed per neighbor
Each PVC can have different CIR,creating an EIGRP packet pacing problem
Multipoint interfaces :
Convert these to point to point configuration or manually configure bandwith by multiplying the lowest CIR by the number of PVC


Configuring EIGRP Bandwith use Across WAN Links




NB : From this picture we assumed there are 10 router which running EIGRP protocol in WAN Connections
So the bandwith calculated with this case is 1/10 of link capacity ( T1 interface as the default )
As described earlier ,the IP bandwith percent eigrp as number-percent commands allow the maximum percentage of bandwith of an interface that the EIGPR will be use
The circuits are provisioned 56 kbps links,but there is insufficient bandwith at the interface to support this allocation

For example if router C trying to communicate with all remote sites it will be need bandwith as 56 * 10 = 560 kbps,it exceed from the available bandwith 256 kbps
On each interface and subinterface,the EIGRP allocation percentage is raised to 110 percent of specified bandwith in an attempt to ensure that eigrp packet are delivered through the frame relay network
This adjustment cause EIGRP packet to receive approximately 28 kbps of the provisioned bandwith 56 Kbps on each circuit
This extra configuration restore 50:50 ration of delivery bandwith

EIGRP WAN Configuration : Hybrid Multipoint




This figure show us that there is link with a lower and higher connection
In point to point (router C) has a lower connection than other because it’s point to point connection
And the other ( point to multipoint ) the bandwith is shared equally among all circuits.
In this case the bandwith is set to 768 kbps,which is the sum of 3 CIR (256*3) = 768
Each link will be allocated one third of this bandwith,resulting 256 kbps each interface

Senin, 23 Februari 2009

Load Balancing in EIGRP

Load Balancing in EIGRP
There can be up to six entries in the routing table for the same destination :
1. The number of entries is configurable
2. The default is four
3. Set to 1 to disable load balancing
Equal cost load balancing is the ability of router to distribute all the traffic over all it’s network port that are the same metric from the destination address
Load balancing increases the use of network segment and increase effective network bandwith
How to configure equal balancing
Router(config-router)#variance multiplier
Variance example :





from this picture we assume router E choose router C to reaching network Z because it have lower FD
with use variance 2 command ,router E choose router B to get network Z
because (20 + 10 ) < (2*(FD)20 =40 )
→ 30 < 40 ( true )
with used variance 2 router D is never considered to get network Z because
(20 +25 ) < (2 *(fd)20)
45 < 40 (false )
NB : if You want router D get network Z you can increase your variance value

Minggu, 22 Februari 2009

EIGRP route summarization

Configuring Advanced EIGRP Options
1.EIGRP route summarization
In order to get the better network performance. You may configure EIGRP routing summarization
By implementing this options in your network,you will be able to have :
1. Smaller routing Update
2. Smaller routing table
You can configuring route summarization with EIGRP protocol with 2 ways ( Auto & Manual )
1. Route Summarization :Auto
On major network boundaries,subnets network are summarized to a single classfull ( Major ) network
Automatic summarization occur by default
2.Route Summarization : Manual
summarization is configured on per-basis interface in any router within a network
when summarization is configured,the router immediately creates a route pointing to null0 ( this is happened as the prevention looping mechanism )

when the last specific route of the summary goes away,the summary is deleted
the minimum metric of the specific routes is used as the metric of the summary route
Configuring route summarization :
(config-router)#no auto-summary
Turn off automatic summarization of EIGRP Process
(config-if)#ip summary-address eigrp as-number address mask
creates summary address that interface will be generate

Example :




From this picture ,router C sees network 172.16.1.0 and 172.16.2.0 but only sends 172.16.0.0 as the routing update to other network


Router C Completed configuration :
Router>enable
Router#configure terminal
Router(config)#router eigrp 100
Router(config-router)#network 10.0.0.0
Router(config-router)#network 192.168.4.0
Router(config-router)#exit
Router(config)#interface serial 0/0/0
Router(config-if)#ip address 192.168.3.2 255.255.255.0
Router(config-if)#ip summary-address eigrp 100 172.16.0.0 255.255.0.0

Sabtu, 21 Februari 2009

Introduction

Hai...

my name is hasudungan perdana cipta sijabat

currently i attended at maranatha christian university

this blog i will used to share my knowledge about Cisco networking

hopefully this blog will be usefull for you and please contact me if i had a mistake during writting this blog

you can contact me to doenkthaxxx@gmail.com

finally..thank you for reading this blog and it's fun to meet you


Best Regards


Hasudungan P.C.Sijabat CCNA,CCNP